0 votes
by (190 points)


I will try to drive the LTP3 of my computer. I'm working with EventIDE 2018-nov-06 on Windows 10. Event IDE see the port "Sunix LPT port (LPT3)" but the address is FFFFFFFF.

I tried the addresses given by Windows, DFB8 to DFBF and DFB0 to DFB7 (extended address).

I wrote these parameters (DFB8 first then DFB0) in the settings of the LPT element but it doesn't seem to work. The seetings of my port are :

  • Preface duration = 0
  • Pulse duration = 1000
  • Interpulse duration = 0
  • Pulse number = 1
  • Output value = 255
  • Signal profile = Pulse |.. -> zero(preface) -> value ->zero

Could you help me ? Thanks in advance.

3 Answers

0 votes
by (14.5k points)
selected by
Best answer

Serge hi,

It seems that auto-detection of the port address by LPT Port element did not work, since 'FFFFFFFF' is an incorrect value, obviously. You are right in trying to enter the base address manually. Normally, the first value that you see in the Device Manager->Port Properties should work for EventIDE. For example, the base address is 0378 in my machine (see the screenshot): 

So, I expect that the base address should be DFB8 on your computer. Other parameters of the LTP port element look correct too, given that your external hardware can read 1 sec pulse.

Can you please try 2 solution:

1. Run EventIDE as a administrator. Sometimes, security settings in Windows can block an application from accessing the parallel port. Alternatively, try to start EventIDE from an administrator account.

2. Use a third-party LPT port tool to check whether the base port address is correct, for example, LPT Debugger. That tool should show you the correct address and whether EventIDE sends a trigger correctly.

If the problem persists, can you connect me by Skype and show your configuration via screen sharing?  My Skype ID is 'corvexx'.








0 votes
by (190 points)

Hello Ilia,

Thank you for your reply.

My account of this computer is a administrator account. If I run EventIDE as administrator, I can drive the LPT with the address base DFB8. I save the new configuration and now if I run the experiment "normally" (not as administrator) I can drive the LPT port.

And if I load an another experiment it's working.

But, for a new experiment, it doesn't work. In this case, I create a new experiment and  I must to do the procedure :

  1. create a new experiment with my lpt port
  2. save experiment
  3. start EventIDE as administrator
  4. load the experiment
  5. set the address : DFB8
  6. send pulse to check the LPT port
  7. save
  8. start EventIDE normally and load the experiment
  9. check the LPT port (and now it's working).

I don't understand.... It seems that the settings are saved only if I am an administrator and after if I load the experiment I can dirve the LPT port without any problem.

I think it only happens on Windows 10, I did not find this problem on Windows 7.

Do you know what's going on?


by (14.5k points)
Serge hi,

That all it very weird and I honestly confused too. I can imagine, that Windows internally sets/resets an kind of allowance flag for EventIDE (when you run it as administrator), but it should work both for new and loaded experiments. Technically, a saved experiment stores the port address as a plain number and its the same as in a new experiment.

Can it be a problem with third-party drivers for the parallel port? It may also explain the fact that you get FFFF out of the port auto-detection in EventIDE, which is abnormal. Do you have similar problemes with other app that use LPT, e.g. LPT debugger?

If you would have time, can you call me in Skype and show that issue on shared screen?
0 votes
by (14.5k points)

Serge hi again,

I had a chance to test EventIDE and the LPT element with a brand new Window 10 installation. To my partial surprise, a story similar to yours has occurred – when I used the LPT element for the first time, it did not send any output. Restarting EventIDE has fixed the issue and (which different to your case) I had no problems since that, whether with a new experiment or saved ones.

To work with the parallel ports, EventIDE uses the InpOut32 library, available on the Highrez website The description there mentions that hardware driver  is included in the library dll and is supposed to install automatically, when you make the first call of the library functions.

My guess, therefore, is that in your system, the driver is forcibly uninstalled each time you quits EventIDE and gets locked in re-installation steps over and over again.

Can you try to download the “Binaries only - x86 & x64 DLLs and libs” package on the highrez website, unzip the content of it, and run InstallDriver.exe tool in the Win32 subfolder (presumably with the admin account)? If the tool installs the port driver permanently into the system, it can fix your problem.

I hope, that it might help.

Welcome to EventIDE Q&A forum where you can ask questions about EventIDE software and receive answers from other members of the community


FAQ questions

Installation and License



EEG Analysis

Visual Stimuli

Runtime and Data Collection